首页 > VPS管理维护 > centos 用yum 升级php到5.2

centos 用yum 升级php到5.2

2011年7月12日 发表评论 阅读评论


最近WordPress出了3.2新版本,可是升级时候提示不再支持PHP5.2版本,所以就得升级PHP, VPS博客采用yum升级php,下面说一下centos下yum升级php的简便方法.

以下升级方法已经博主测试很成功,完美升级! 升级后php版本是5.2.9, yum升级php命令如下:

rpm -Uvh http://repo.webtatic.com/yum/centos/5/latest.rpm

yum –enablerepo=webtatic –exclude=php*5.3* update  mcrypt mbstring php-mbstring php-mcrypt

service httpd restart

执行以上yum升级命令后,再输入php -v  看一下升级情况,不出意外的话就升级成功了!

在写两个升级php的方法. 注以下未测试.  未测试方法1

rpm –import http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

vi /etc/yum.repos.d/CentOS-Base.repo 增加下面信息

[utterramblings]
name=Jason’s Utter Ramblings Repo
baseurl=http://www.jasonlitka.com/media/EL$releasever/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

执行命令,自动升级。

yum update php -y
yum install libmcrypt -y

未测试方法2

以下在CentOS5.4用yum安裝PHP5.2.9的步驟。首先在/etc/yum.repos.d/CentOS-Base.repo 文件最底部添加如下代码:
 
[c5-testing]
name=CentOS-5 Testing
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/
enabled=0
gpgcheck=1
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
 
然后保存此文件,执行yum –disablerepo=\* –enablerepo=c5-testing install php 接着根据提示输入Y同意执行安装即可

还是第一个yum升级php到5.2版本的方法简单, 免去了vi编辑等繁琐过程! 推荐! 

转载请注明: 转载自VPS博客 centos 用yum 升级php到5.2

本文链接地址: http://www.vpsboke.com/manage/centos-yum-update-php/


分类: VPS管理维护 标签: ,
  1. 本文目前尚无任何评论.
  1. 本文目前尚无任何 trackbacks 和 pingbacks.
😉 😐 😡 😈 🙂 😯 🙁 🙄 😛 😳 😮 mrgreen.png 😆 💡 😀 👿 😥 😎 ➡ 😕 ❓ ❗